Sonar cli Detected project binding: ERROR - Apple M1

  • ALM used Manual

  • CI system used Github

  • Scanner command

sonar-scanner \
-Dsonar.organization=plantyouridea \
-Dsonar.projectKey=plantyouridea_adapt_authoring \
-Dsonar.sources=. \
  • Languages of the repository: JavaScript

  • Only if the SonarCloud project is public, the URL

INFO: Scanner configuration file: /Users/cs/dev/sonar/sonar-scanner-

INFO: Project root configuration file: NONE

INFO: SonarScanner

INFO: Java Eclipse Adoptium (64-bit)

INFO: Mac OS X 12.6 x86_64

INFO: User cache: /Users/cs/.sonar/cache

INFO: Scanner configuration file: /Users/cs/dev/sonar/sonar-scanner-

INFO: Project root configuration file: NONE

INFO: Analyzing on SonarCloud

INFO: Default locale: "en_IN", source code encoding: "UTF-8" (analysis is platform dependent)

INFO: Load global settings

INFO: Load global settings (done) | time=978ms

INFO: Server id: 1BD809FA-AWHW8ct9-T_TB3XqouNu

INFO: User cache: /Users/cs/.sonar/cache

INFO: Load/download plugins

INFO: Load plugins index

INFO: Load plugins index (done) | time=918ms

INFO: Load/download plugins (done) | time=21170ms

INFO: Loaded core extensions: developer-scanner

INFO: Load project settings for component key: 'plantyouridea_adapt_authoring'

INFO: Process project properties

INFO: Execute project builders

INFO: Execute project builders (done) | time=5ms

INFO: Project key: plantyouridea_adapt_authoring

INFO: Base dir: /Users/cs/dev/adapt_authoring

INFO: Working dir: /Users/cs/dev/adapt_authoring/.scannerwork

INFO: Load project branches

INFO: Load project branches (done) | time=869ms

INFO: Check ALM binding of project ‘plantyouridea_adapt_authoring'

WARN: Failed to check if project ‘plantyouridea_adapt_authoring' is bound

INFO: Detected project binding: ERROR

INFO: Check ALM binding of project ‘plantyouridea_adapt_authoring' (done) | time=862ms

INFO: Load project pull requests

INFO: Load project pull requests (done) | time=881ms

INFO: Load branch configuration

INFO: Load branch configuration (done) | time=10ms

INFO: Load quality profiles

INFO: ------------------------------------------------------------------------


INFO: ------------------------------------------------------------------------

INFO: Total time: 46.653s

INFO: Final Memory: 20M/77M

INFO: ------------------------------------------------------------------------

ERROR: Error during SonarScanner execution

ERROR: Project not found. Please check the 'sonar.projectKey' and 'sonar.organization' properties, the 'SONAR_TOKEN' environment variable, or contact the project administrator


ERROR: Re-run SonarScanner using the -X switch to enable full debug logging.

I tried deleting .sonar folder in home folder and running again, but still getting the same issue.


Welcome to the community!

You appear to be passing in the project key and organization. What about the permissions token SONAR_TOKEN?


SONAR_TOKEN is set in the environment variable. I am able to validate using echo $SONAR_TOKEN.

Sonar Cli documentation:

Adding -Dsonar.login=TOKEN worked for me, complete run command looks like below:

sonar-scanner \
  -Dsonar.organization=plantyouridea \
  -Dsonar.projectKey=adapt_authoring \
  -Dsonar.sources=. \ \
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.