Sonar Analysis Branch is not populating in sonar Cloud

Hi Alex, I got the access and I have removed few of the short lived branches as you suggested. Still I can see there is no luck. We are not able to get analysis for any branch . As per logs It shows as its pushing analysis with branch name but in sonar cloud , branch is not available. Can you please check this in priority. Thanks.

Hi Prakash,

I am sorry if the removal you did was not sufficient to work around the issue.
I’ve opened a change ticket to get the service improved to cope with this scenario.

In the meantime, in an attempt to work around the problem, I would still recommend continue closing unused short-lived branches and pull requests, as I could see the step that is timing out is now taking less time than before.


Thanks Alex . Can you please let me now is there any change made in sonar cloud which resulted in this issue. This used to work previously, and we were able to see the branch in sonar cloud after sonar analysis but suddenly this issue popped up and now, we are not able to scan our code. We have disabled all our sonar analysis and publish step.

Hi, @prakashmenon19 - not to my knowledge. From my investigation, the issue seems to come from the shape of the project data itself.

Hi Alex, this used to work previously with no issues and suddenly we are not able to see branches in sonar cloud or its not updating with latest analysis report. The code or the project data is untouched. No change to data. We have tried with creating new branch, run analysis but still no luck. Branch itself not available in sonar cloud. Can we have a meeting on this so we can screen share and show what is happening. This is going round and round with no solution. Sonar cloud is not working for us and this process threat to quality of code which is getting deployed.

Hi @prakashmenon19

I see recent analyses went through. Could you confirm the issue is now solved?

Hi Alex Issue is not resolved yet . Issue with UI Sonar Analysis still persist . We are checking on it . If you are referring to issue raised in Sonarcloud Publish Task failed in Azure DevOps with Operation cancelled - SonarCloud - Sonar Community ( then that issue is w.r.t API sonar analysis which is some what working now after deleting all short lived branches.