Scan C/C++ (with Community Plugin) with Leak Period

Hi ,

When I scan my C/C++ code with Leak Period , I have a problem at the 3 scan: First Scan is the basic with the Leak Period Second scan is with the current code , I see the results well Third scan like the second , but I don’t see Coverage and new lines

Attached screenshots from all the scans.

Thanks :slight_smile: Chen

I tried at 6.7.2 and 7.4 version of SOnarQube. I tried to scan with Leak Period at every scan , but didn’t work. Then scanned the first time with Leak Period , the second time without and it was OK , at the Third scan I have the same problem.

I scan with the following command: /opt/sonar-scanner-3.0.3.778/bin/sonar-scanner -Dsonar.login=XXXXX -Dsonar.password=XXXXX -Dsonar.scm.forceReloadAll=true -Dsonar.sources=/var/lib/jenkins/workspace/DEBUG_Client_Scan_Code_By_SonarQube/vdm-11.7 -Dsonar.cxx.includeDirectories=sdk/source/engine/restapi/ -Dsonar.exclusions= /external/ , /dma/app/linux2/client/ , /dma/scripts/ , /dma/app/linux2/ec_client/client/peripheral/rb/ -Dsonar.language=c++ -Dsonar.projectKey=vdm-11.7

I expect that after the first scan , every scan for the same project will show the “Coverage %” and “New lines to Cover” witht the right valuesenter image description here

Thanks
Chen

Hi Chen,

Please report problems with the community Cxx plugin in that community.

 
Ann

1 Like