SAML Error: Doesn't match configured ACS URL

Hi all
I’m receiving an error on Google SAML login on SonarQube v after setting up the Google SAML login. Ive set up a custom domain via Apache, and added the ProxyReverse etc needed, however, I cannot get around this error if anyone can help?

You’re not authorized to access this page. Please contact the administrator.

Reason: The status code of the Response was not Success, was urn:oasis:names:tc:SAML:2.0:status:Requester → Invalid request, ACS Url in request http://127.0.0.1:9000/oauth2/callback/saml doesn’t match configured ACS Url https://sonarqube.customdomain.co.uk/oauth2/callback/saml.

Hi,

Welcome to the community!

Have you set your Server Base URL? Administration → General Settings.

 
HTH,
Ann

Thanks for the reply Ann

I have now added this and now receiving:
Reason: The response was received at http://sonarqube.customdomain.co.uk/oauth2/callback/saml instead of https://sonarqube.customdomain.co.uk/oauth2/callback/saml

I’m going to do some further digging.

Hi,

This should help:

 
Ann

This is now resolved and working, I had to change the Apache settings to:
HTTP:
ProxyRequests Off
ProxyPreserveHost On
ServerName sonarqube.customdomain.co.uk
ProxyPass / https://127.0.0.1:9000/
ProxyPassReverse / http://sonarqube.customdomain.co.uk/

HTTPS:
ProxyRequests Off
ProxyPreserveHost On
RequestHeader set X-Forwarded-Proto “https”
ServerName sonarqube.customdomain.co.uk
ProxyPass / http://127.0.0.1:9000/
ProxyPassReverse / https://sonarqube.customdomain.co.uk/

1 Like