Report processing is taking longer than the configured wait limit

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    Sonarqube community Edition 8.1
  • what are you trying to achieve
    When trying to do sonar scan, failing with below output

running sonar scan [Pipeline] sh + export ‘JAVA_HOME=/usr/lib/jvm/java-1.8-openjdk’ + export ‘PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/lib/jvm/java-1.8-openjdk/bin’ + /opt/gradle-7.3.3/gradle-7.3.3/bin/gradle sonarqube Starting a Gradle Daemon, 1 incompatible and 2 stopped Daemons could not be reused, use --status for details > Task :processResources UP-TO-DATE > Task :processTestResources NO-SOURCE > Task :generateJsonSchema2DataClass0 > Task :generateJsonSchema2DataClass > Task :compileJava UP-TO-DATE > Task :classes UP-TO-DATE > Task :compileTestJava UP-TO-DATE > Task :sonarqube SonarScanner will require Java 11 to run starting in SonarQube 8.x Plugin SonarQube CNES Report [cnesreport] uses a child first classloader which is deprecated Property ‘sonar.jacoco.reportPath’ is deprecated (JaCoCo binary format). ‘sonar.coverage.jacoco.xmlReportPaths’ should be used instead (JaCoCo XML format). Please check that the JaCoCo plugin is installed on your SonarQube Instance.

[BUILD BREAKER] API query limit (30) reached. Try increasing sonar.buildbreaker.queryMaxAttempts, sonar.buildbreaker.queryInterval, or both. > Task :sonarqube FAILED FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ‘:sonarqube’. > Report processing is taking longer than the configured wait limit. * Try: > Run with --stacktrace option to get the stack trace. > Run with --info or --debug option to get more log output. > Run with --scan to get full insights. * Get more help at https://help.gradle.org Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0. You can use ‘–warning-mode all’ to show the individual deprecation warnings and determine if they come from your own scripts or plugins. See Command-Line Interface BUILD FAILED in 5m 33s 5 actionable tasks: 2 executed, 3 up-to-date [Pipeline] echo SONAR scan or quality gate check was unsuccessful

  • what have you tried so far to achieve this
    It was working with old version of postgres db(10.18), the exception is coming after upgrading to 12.8

Thanks
Ramani

Hi,

Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.1 → 8.9.9 → 9.6.1 (last step optional)

You may find the Upgrade Guide and the LTS-to-LTS Upgrade Notes helpful. If you have questions about upgrading, feel free to open a new thread for that here.

Beyond that, the Build Breaker plugin is not one we support. We recommend you pause the pipeline until the Quality Gate is computed.

 
Ann

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.