Pull request decoration did not happen. The sonarcloud organization is not bound to Bitbucket Cloud

  • Bitbucket Cloud / Pipelines / Gradle

Our integration between SonarCloud and BitBucketCloud seems to have an issue. The PR’s are recorded in sonarcloud, but we always see this warning:

Pull request decoration did not happen. The SonarCloud organization is not bound to Bitbucket Cloud. Please install the SonarCloud application on Bitbucket Cloud, or read "How to bind an existing organization?" section in the "Organizations" documentation page to fix your setup.

We’ve tried removing the Add-On in BBC, but whatever we do we can’t get the organization to ‘unbind’ in SonarCloud. It seems it’s still link to an old (personal) bitbucket account instead of the team account.

Can you show exactly what you’ve done (share some screenshots, perhaps?).

Typically to unbind the organization, you need to uninstall the SonarCloud application from your Bitbucket workspace. Is this what you meant by “removing the add-on”?

An organization is then bound/rebound in the organization level Administration > Organization Management on SonarCloud.

@Colin yes, that’s correct. We removed the Add-On, even revoked API keys, but on the sonarcloud.io website it still shows as ‘Bound’. See screenshots.


Thanks for looking into this.
Kind regards, Barry

@Barry_Lagerweij1

That’s strange. As soon as I remove the SonarCloud application from a Bitbucket workspace, I’m prompted to rebind on SonarCloud. To me, this would indicate that the application isn’t being uninstalled from the right workspace.

I have two questions:

  • Do the links in the SonarCloud UI link to the old personal organization, or the new (intended) organization
  • How have you reinstalled the SonarCloud application (which it appears you must have, since it’s still visible in the list of installed apps where you an click “remove”)?

@Colin I think you’re on the right track here, the link in the Sonarcloud UI indeed point to our old BitBucket account (which is not a team account, but a personal account). I was able to remove the Sonarcloud integration on the old account, but when I bind to the new organization, it’s asking me to choose a organization key and enter credit card details again. How do I bind to an existing organization?

Barry

Hey @Barry_Lagerweij1

Thanks for the further details.

I was able to reproduce the issue when I tried to bind my SonarCloud account to a Bitbucket workspace that my SonarCloud user (or more accurately stated, the Bitbucket account tied to my SonarCloud user) isn’t a member of (you can check which account you are using by browsing https://sonarcloud.io/account).

Once I added that account to the Bitbucket workspace I was ultimately trying to bind to (and logged back into my original SonarCloud account), the binding was completed successfully without being prompted to create a new organization.

Could that be what’s happening here?

Looks like the unlinking and relinking worked in the in the end, the new PR’s do not show that warning anymore. The PR show the bitbucket logo, and we have the reports back in BitBucket.
Thank you for the assistance.
Kind regards, Barry