Pull request analysis was successful, but branch analysis always showed background task failed

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    Sonarqube: Enterprise edition 9.7.1
    database: postgresql 14.2 in docker

  • what are you trying to achieve
    build a jenkins job,analyze a bitbucket branch successful.

  • what have you tried so far to achieve this
    Create a new sonarqube project with build-in profile, branch analysis points to the newly created project, but also shows that the background task failed.

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

background_jenkins.log (24.5 KB)

Hi,

We worked on something very similar to this in 9.8:

SONAR-17597 NullPointerException when CE loads SCM changesets from DB

Can you upgrade and try again?

 
Ann

YES,we upgrade to enterprise edition 9.8 and then background task failed again.

Hi,

Thanks for trying. I’m going to flag this for team attention.

 
Ann