Problem while upgrading from 6.7.6 LTS to 7.9.4 LTS

As mentioned in the Title I was doing upgrade from one Sonar LTS version to another and in that process I was also switching DB engine from MySQL to PostgreSQL and migrating data using SonarQube DB Copy Tool that was provided by Sonar. Everything finished successfuly, without any errors.
I am attaching log from when I ran DB Copy tool (file: dbmiglog) and also Sonar DB upgrade script from when I first started Sonarqube 7.9.4 on the target node (file: sonardbupgradescript).
The problem is that now I see everything in the UI but there are some things that are messed up like they are not rendered properly:

  • In footer section instead of text License or LGPL v3 it says: footer.license
  • instead of 91k I get 91short_number_suffix.k

I tried to find what could cause the issue, but I can’t find anything wrong with the installation. Could someone please assist? (7.9 KB)
Settings section in new Sonar installation
Project in new Sonar

That same project in old Sonar

Hi there @ailijevski,

These strange labels that you see are actually our internal translation keys (see this link for an example).

Seeing those keys means that the web application wasn’t able to find the translation associated to it. Still, we can see that it was able to find the translation for most of them.

In order to remove any cache suspicion, I’d like to ask you if you already tried to clear your browser cache? If not, it usually is easy to do so with CTRL+R or CTRL+SHIFT+DEL (of course it might depend on the browser you’re using).

Let me know if it helps


Hi @Philippe_Perrin
Thank you for your reply. Actually since this looked like UI/rendering issue the first thing I tried is logging in to WebUI using Incognito mode, where the cache is not preserved. I now tried again to clear the cache(using dev tools in Chrome) and then loaded the pages but the problem still persists. Please advise.

In order to understand if the problem is coming from the web application or from the server, I’d like you to check out the local storage of the navigator while browsing SonarQube.

You should find 3 key/value pair that have a name prefixed by l10n:

  1. l10n.locale
  2. l10n.timestamp
  3. l10n.bundle

I’m mostly interested by the content of l10n.bundle. Do you find the problematic key in it? footer.license |

Could you provide values for those 3 key/values pair?

Some of them can be found there (for example: footer.license) and some of them are missing. Here are the values of the keys in each file.
l10n.timestamp.json (25 Bytes) l10n.locale.json (3 Bytes) l10n.bundle.json (215.9 KB)

You can also check out how this page was rendered

Actually none of them is present in the translation bundle you sent me. You did found footer.licence but not footer.license :slight_smile: .

I think it is now safe to assume that the web application is just fine and that the issue is coming from the server side. The translation bundle provided by the server is not aligned with the web application version.

I suspect an issue during the upgrade of the server. Did you extract the new version of SonarQube in a fresh directory as mentioned in our upgrade documentation?

You were right, I’ve misread that. The problem was with one of the plugins which was causing the mentioned behaviour: sonar-l10n-ru-plugin-1.8.jar. Since I’ve installed this new version of SonarQube on totally different server the only thing that I copied from the old server was /plugins folder which lead me to conclusion that the problem is probably there. Deleting the mentioned plugin solved the issue immediately.

Thank you for your quick responses and help during solving of this issue! I appreciate it.

Have a nice weekend and happy Friday!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.