PR checks stopped working and only shows 'waiting for checks information' message

  • SonarQube developer edition * Version 8.3.1 (build 34397)
  • ‘waiting for checks information’ message appears instead of showing PR analysis in github
  • HOWTO reproduce: Run PR analysis and Open Checks tab in Github PR

PR feature just stopped working.

Hi @Tatiana_Kudryavtseva,

Can you please confirm a few things:

  • Are you using or GitHub Enterprise ?
  • Are the PRs getting analyzed? (Do you see them on SonarQube?)
  • When you look at a PR on SonarQube:
    • do you see the link to the PR in the top-right corner?
    • do you see a warning box (in yellowish background) in the top-right corner?

Do you see anything in the ce.logs of SonarQube ? If not, can you turn on the DEBUG mode to see if anything happens when a PR gets decorated ?


We are using Github Enterprise
PRs are getting analyzed but not sent to Github
I see the link yes
All warnings were resolved
In logs there is nothing about Pull Requests and even if I change the logs to more verbose.
Thanks for looking at it, Aurélie!

Thanks for your reply.

Few more questions then :slight_smile:

  • What version of Github Enterprise are you using ?
  • Do you see the comment in the Conversation tab in GH, like this one:


Hi @aurelie, I am using 2.19.14 Github Enterprise Server version .
Comments on the conversation tab also not working.

Thanks for looking at it!


You probably have done an upgrade of your Github Enterprise recently, right? I see that 2.19.16 was released on 23th of June. I don’t see the 2.19.14 though.

Does PR decoration not work anymore since you have upgraded GH Enterprise?


The PR decoration doesn’t work anymore yes, but I am not sure if we upgraded github enterprise recently or the reason in something else. Do you think it doesn’t work with the new GITHUB version?

Hi @aurelie the version of github that we are using is just one month old -

Hi @Tatiana_Kudryavtseva,
Thanks. I can’t find anything in the release notes of GHE that could indicate an incompatibility.

Could you please enable debug logs in the Compute Engine process (CE) and check the logs when the problem occurs?

HI @dmeneses all right, thanks!

Any updates here, i have the same issue using recent GH 2.19.X and SQ 7.9

We just did recommended configurations recently and see request response with response body html from SQ but not displayed in checks view, only waiting for checks … is displayed

Just a note here that we see although checks from circleci so ‘checks’ is not completely broken but only SQ checks are not shown

Hi @dmeneses

We have some similar issue (LTS 7.9 and using ).

We have opened a support ticket SUPPORT-21607

By enabling DEBUG logs we don’t see anything expect a 404 without error message

2020.10.15 17:30:33 DEBUG ce[AXUtUDAUG5Khf6ut9h-Z][c.s.C.A.C.A.B.D] POST response did not have expected HTTP code (was 404):
2020.10.15 17:30:33 INFO ce[AXUtUDAUG5Khf6ut9h-Z][o.s.c.t.CeWorkerImpl] Executed task | project=************** | type=REPORT | pullRequest=2 | id=AXUtUDAUG5Khf6ut9h-Z | submitter=******* | status=SUCCESS | time=1698ms

Any idea ?


Hi all, for us it’s still not working. It worked for a few weeks and broke again with no reason and no changes done.
Could you please help to debug it? @dmeneses

This is exactly our situation, we are using sonarqube 8.4.1 vs
Pull request decorations are reported to be successful, but they do not appear in the github pr comments or checks, and we see two associated entries of debug logs every time
[] TLSHandshake:, TLSv1.3, TLS_AES_128_GCM_SHA256, -526691440:
[c.s.C.A.C.A.B.D] POST response did not have expected HTTP code (was 404):
[c.s.C.A.C.A.B.D] POST response did not have expected HTTP code (was 404):
[o.s.c.t.p.a.p.PostProjectAnalysisTasksExecutor] Pull Request decoration | status=SUCCESS | time=388ms

There is a slight clue in github api docs regarding this:

Requests that require authentication will return 404 Not Found , instead of 403 Forbidden , in some places. This is to prevent the accidental leakage of private repositories to unauthorized users.

@aurelie @dmeneses

@jonesbusy were able to get any solutions on your support case?