Plugins refuse to load after upgrade

ldap
sonarqube

(Kevin Williams) #1

I’m upgrading a test instance from 5.6.6 to 6.7.4 and am upgrading the plugins too. It seems it is not loading any plugins.

2018.08.02 18:08:43 INFO  app[][o.e.p.PluginsService] no modules loaded
2018.08.02 18:08:43 INFO  app[][o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]

There should be six scanner plugins and the LDAP plugin, but nothing loads. Without the LDAP plugin, we cannot log in. I’ve tried DEBUG log level but no further pertinent details are given. I’ve tried having just the LDAP plugin but it still will not load any added plugins.

Unfortunately, the database upgrade seemed to go through successfully, so the instance is in a broken limbo until I can either get the plugins working or roll everything back, which I’d rather not do.


(G Ann Campbell) #2

Hi,

What directory did you put the plugin in?

Also, does anything show up in any of your server logs ($SONARQUBE_HOME/logs)?

Ann


(Kevin Williams) #3

Hi Ann, thanks for replying.

The plugins are in the documented default location, $SONARQUBE_HOME/extensions/plugins, which on our setup is /usr/local/sonarqube-6.7.4/extensions/plugins. The $SONARQUBE_HOME directory tree is owned by the ‘sonar’ user, and the process runs as the ‘sonar’ user.

The only thing about plugins I can find in the logs is the two lines I included already, even when I set logging to DEBUG level.

Thanks!


(Simon Brandhof) #4

Can you send the full logs please, including web.log and ce.log ?


(Kevin Williams) #5

Hi Simon,

Your question led me to discover that the plugin loading and LDAP connection are being logged in web.log rather than sonar.log. I’m guessing that changed in the version upgrade. Anyway, the plugins are loading and the LDAP connection tests OK, so we can consider this resolved. Thanks!