Plugin 3.3 for devops not compatible with Gradle 7

I follow up on the post https://community.sonarsource.com/t/sonarcloud-not-compatible-with-gradle-7/47613

the sonarqube plugin on the azuredevops server unfortunately does not work correctly with the gradle version 7

for work needs I had to continue developing with the old version of the gradle to be able to run the build.
Unfortunately I still get an error if I update the gradle version.
No error is detected with the old version.
I paste below all the details of my code and the error I have in the build.
The plugin version is 3.3

Thanks

buildscript {
    ext.kotlin_version = '1.5.21'
    repositories {
        google()
        mavenCentral()
        gradlePluginPortal()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:7.0.2'
        classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
        classpath 'com.google.gms:google-services:4.3.10'

        // Add the dependency for the Performance Monitoring plugin
        classpath 'com.google.firebase:perf-plugin:1.4.0'
        classpath 'com.google.firebase:firebase-crashlytics-gradle:2.7.1'
// Performance Monitoring plugin

    }
}

allprojects {
    repositories {
        google()
        mavenCentral()
        gradlePluginPortal()
    }
}
  compileSdkVersion 31

    defaultConfig {
        configurations.all {
            resolutionStrategy { force 'androidx.core:core-ktx:1.6.0' }
        }

        applicationId "fr.genapi.mygenapi"
        minSdkVersion 28
        targetSdkVersion 31
        versionCode 17
        versionName "1.0"


        testInstrumentationRunner "androidx.test.runner.AndroidJUnitRunner"
        signingConfig signingConfigs.MyGenapiSign
    }


kotlinOptions {
        jvmTarget = '1.8'
    }
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_8
        targetCompatibility JavaVersion.VERSION_1_8
    }
    ndkVersion '22.0.7026061'

error build

> Task :app:lintDebug FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:lintDebug'.
> A failure occurred while executing com.android.build.gradle.internal.lint.AndroidLintTask$AndroidLintLauncherWorkAction
   > There was a failure while executing work items
      > A failure occurred while executing com.android.build.gradle.internal.lint.AndroidLintWorkAction
         > Lint found errors in the project; aborting build.

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 2m 2s
97 actionable tasks: 29 executed, 68 up-to-date
Error: The process 'D:\agent\_work\1\s\gradlew.bat' failed with exit code 1
    at ExecState._setResult (D:\agent\_work\_tasks\Gradle_8d8eebd8-2b94-4c97-85af-839254cc6da4\2.181.0\node_modules\azure-pipelines-task-lib\toolrunner.js:937:25)
    at ExecState.CheckComplete (D:\agent\_work\_tasks\Gradle_8d8eebd8-2b94-4c97-85af-839254cc6da4\2.181.0\node_modules\azure-pipelines-task-lib\toolrunner.js:920:18)
    at ChildProcess.<anonymous> (D:\agent\_work\_tasks\Gradle_8d8eebd8-2b94-4c97-85af-839254cc6da4\2.181.0\node_modules\azure-pipelines-task-lib\toolrunner.js:833:19)
    at ChildProcess.emit (events.js:182:13)
    at maybeClose (internal/child_process.js:962:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:251:5)
##[error]Error: The process 'D:\agent\_work\1\s\gradlew.bat' failed with exit code 1

Hi @HydraRock

We don’t see any mention to SonarQube plugin here, and the failing task doesn’t seem to have anything to do with our Scanner. Maybe you can check what’s wrong with it ? Running it locally if possible may help.

HTH,
Mickaël

Hello @mickaelcaro , thanks
the local build works fine.
The build on the server does not work.
If I run the build with version 4.2.2, everything works fine.

if I suspend the SonarQube control from the Pipelines, the build comes to an end on the server as well

**


**