Not able to load sonar site with domain name

Hi Team,

When I’m accessing sonar through http://localhost:9000 its working fine but when I’m accessing it using computer name like computername.dir.svc.companyname.com it keep showing loading but it doesn’t load.

Could you please tell me what is the issue.
Untitled

Can anyone reply, please.

Hello @Rasik_Bapotra,

What version of SonarQube are you using?
Did you set Server base URL in Administration->General settings -> General?
Can you ping that hostname through CMD? Do you get any response?

Cheers,
Jacek

Hi Jacek,

I tried setting base url as http://computername.dir.svc.companyname.com:9000.
Sonar is hosted on AWS EC2 server. I can able to see dashboard using http://localhost:9000 but not using http://computername.dir.svc.companyname.com:9000 on same hosted(local) machine . It keep showing loading as shown in last message attachment.

I’m using latest community version 8.x.x

Is it self compiled version of SQ? Please be specific on that part, there are differences between 8.X versions. We had an issue on IE, which has been resolved recently, so maybe try different browser depending on the version you are using.

I’m using Sonarqube community version- 8.4.1.35646. Also I am using IE. I’ll test using chrome after installing chrome browser on server. Would you like me to verify any further details?

Yes, if it is possible please share logs from web.log file and check in the browser if there are any JS issues.

I’m able to ping server from CMD. New browser installation is restricted on server.
web.log (10.2 KB)

Yes it worked. Javascript was disabled. I have enabled it here:

What is the purpose of Server base URL in Administration->General settings -> General? Right now I didn’t set.

1 Like

Cool that you’ve figure it out!

Server base URL is used to provide your SQ domain address for auth purposes, notifications and links in PR decoration (for DE+ editions).

What should be my server base address URL? Is it [http://computername.dir.svc.companyname.com:9000] or [http://computername.dir.svc.companyname.com] or
[computername.dir.svc.companyname.com]

According to what you have described, it should be http://computername.dir.svc.companyname.com:9000, so that generated links will work properly.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.