No Repositories found

  • ALM used: Azure DevOps
  • CI system used: Azure DevOps

When we tried to select a repository, it says none were found.

Screenshot 2020-12-18 070321

Update: the instructions say to just grant your personal token the Code Read/Write permissions, but obviously something more is needed. I tried with a new token that has expanded privileges, and that fixed the issue. I’m not 100% sure which ones were needed to actually fix the issue.

Hi @David_Hefley

From which kind of user have you created this PAT ? Does it have proper access to projects that you want to query ?

The PAT was created by a user that had full rights over all projects. It was definitely some additional need to grant more than just Code Read/Write permissions to the PAT.

Seems weird, we haven’t seen such behavior on our side. Which kind of permissions did you have to add to get your repo listed ?


So - I added full permissions (all), an then it was able to pull the repo list. Today, I revoked that token and added a new one with just Code -> Read/Write as per the documentation, and it continued to work. Perhaps it was a temporary issue last week? It appears resolved now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.