No error are raised considering the set of rules configured on Sonar Server

sonarlint
intellij

(Nicolas Triquenaux) #1

I have installed the sonarLint plugin for pycharm and i have troubles with its scanning results.

Setup :

PyCharm :

PyCharm 2018.3.4 (Community Edition)
Build #PC-183.5429.31, built on January 29, 2019
JRE: 1.8.0_152-release-1343-b26 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.3

SonarLint

v4.0.2.3009

SonarQube

6.7.6.38781

I do have configured the connection to the server, i have selected the desired project in the interface… The whole installation process worked like a charm. I tried to lint a file with expected errors (i have set numerous rules about import problem, and made intentional errors that should be seen by sonarLink. Side note : they are properly caught with sonnar-scanner)

In a nutshell : I have no errors reported by sonarLint when lots should be seen.

In the logs below i see two things that raises questions on my side :

  • No analysis configurator found : what is the meaning of this ? i missed something ?
  • py: AWjrrlOCvsWJ9t0N3-y3 (16 rules) : Why is this random text ? and not nicely formated like the other quality profiles ?

Logs

I have set the verbose log of the plugin an here are them. I did removed part to keep them clear

Update bindings :

Create : […]/Library/Preferences/PyCharmCE2018.3/sonarlint/plugins
Plugin cache: […]/Library/Preferences/PyCharmCE2018.3/sonarlint/plugins
Create : […]/Library/Preferences/PyCharmCE2018.3/sonarlint/plugins/_tmp
GET 200 http://my_sonaqube_server:9000/api/system/status | time=37ms
GET 200 http://my_sonaqube_server:9000/api/plugins/installed | time=14ms
GET 200 http://my_sonaqube_server:9000/api/settings/values.protobuf | time=39ms
Code analyzer ‘scmgit’ is not compatible with SonarLint. Skip downloading it.
Code analyzer ‘github’ is not compatible with SonarLint. Skip downloading it.
GET 200 http://my_sonaqube_server:9000/api/rules/search.protobuf?f=repo,name,severity,lang,htmlDesc,[…] | time=61ms
GET 200 http://my_sonaqube_server:9000/api/rules/search.protobuf?f=repo,name,severity,lang,htmlDesc,[…] | time=617ms
GET 200 http://my_sonaqube_server:9000/api/rules/search.protobuf?f=repo,name,severity,lang,htmlDesc,[…] | time=1492ms
GET 200 http://my_sonaqube_server:9000/api/rules/search.protobuf?f=repo,name,severity,lang,htmlDesc,[…] | time=133ms
GET 200 http://my_sonaqube_server:9000/api/rules/search.protobuf?f=repo,name,severity,lang,htmlDesc,[…] | time=70ms
GET 200 http://my_sonaqube_server:9000/api/qualityprofiles/search.protobuf?organization=default-organization | time=46ms
GET 200 http://my_sonaqube_server:9000/api/components/search.protobuf?qualifiers=TRK&organization=default-organization&ps=500&p=1 | time=46ms
Create : […]/Library/Preferences/PyCharmCE2018.3/sonarlint/plugins
Plugin cache: […]/Library/Preferences/PyCharmCE2018.3/sonarlint/plugins
Create : […]/Library/Preferences/PyCharmCE2018.3/sonarlint/plugins/_tmp
Load plugins
Load plugins (done) | time=2ms
Plugins:

  • SonarPython 1.12.0.2726 (python)
  • SonarJava 5.10.2.17019 (java)
  • SonarJS 5.0.0.6962 (javascript)
    Using storage for server ‘Sonar_QA’ (last update 2/14/19 11:37 AM)
    Server binding ‘Sonar_QA’ updated
    GET 200 http://my_sonaqube_server:9000/api/qualityprofiles/search.protobuf?[…] | time=44ms
    GET 200 http://my_sonaqube_server:9000/api/settings/values.protobuf?[…] | time=67ms
    GET 200 http://my_sonaqube_server:9000/api/components/tree.protobuf?[…] | time=16ms
    GET 200 http://my_sonaqube_server:9000/batch/issues?[…] | time=62ms
    GET 200 http://my_sonaqube_server:9000/api/components/tree.protobuf?[…] | time=22ms
    Project ‘MY:PROJECT:KEY’ in server binding ‘Sonar_QA’ updated
    Clearing all issues because binding was updated

Linting output (for one file):

Trigger: ACTION
[Action] 1 file(s) submitted
No analysis configurator found
Using configuration of ‘MY:PROJECT:KEY’ in server ‘Sonar_QA’
Analysing ‘init.py’…
Starting analysis with configuration:
[
projectKey: MY:PROJECT:KEY
baseDir: […]/Github/my_folder
workDir: […]/Github/my_folder/.idea/sonarlint
extraProperties: {}
inputFiles: [
file://[…]/Github/my_folder/some/path/init.py (UTF-8)
]
]

Available languages:

  • Python => “py”
  • Java => “java”
  • JavaScript => “js”
    Start analysis
    Declared extensions of language Python were converted to py: /.py
    Declared extensions of language Java were converted to java: **/
    .java,
    /.jav
    Declared extensions of language JavaScript were converted to js: **/
    .js,/*.jsx,/*.vue
    Index files
    Language of file ‘file://[…]/Github/my_folder/some/path/init.py’ is detected to be ‘py’
    1 files indexed
    Quality profiles:
  • java: java-project-72600 (241 rules)
  • js: js-project-97029 (79 rules)
  • py: AWjrrlOCvsWJ9t0N3-y3 (16 rules)
    ‘JavaSquidSensor’ skipped because there is no related file in current project
    Execute Sensor: Python Squid Sensor
    Setting filesystem encoding: UTF-8
    Execute Sensor: JavaXmlSensor
    ‘SonarJS’ skipped because there is no related file in current project
    Done in 52ms

Processed 0 issues in 0 ms
Found 0 issues