Language setting not saving in tsql project

Template for a good new topic, formatted with Markdown:

  • We have a basic database in Azure DevOps / github with .sql files.
  • The pipeline is a very basic Azure DevOps build, with just the two sonarcloud steps (prepare and analyze)
  • We’re running it in the GUI of azure devops.
  • This is a TSQL repo
  • The project is private
  • When we go in the GUI to set the language, we choose tsql from the dropdown, we add .sql, etc to the extensions.
    Then we come back to the page, and the language settings are blank again, and the project shows plsql as the language again. It is not taking the changes. I am a super admin.
    What can we do to fix this?

Hi @nbraasch

To clarify, when you say “we go in the GUI to set the language”, do you mean the “General Settings” page in the project > Administration menu in SonarCloud?

If so, the dropdown is only used to display the relevant set of settings per language, it is not a saved setting on the project. There is no need to set the language at the project level, the languages in the repo are detected using the file extensions you are trying to configure. It is normal that it is blank again when you come back to the page.

About the file suffixes, when you change them, do you click on the “Save” button after adding the relevant extensions?

If the changes are not saved, the setting appears on a yellow background.

After clicking the “Save” button, the yellow background disappears, and you should see during a few seconds a green checkmark with the “Saved” message to confirm the setting has been saved, and then they should still be there the next time you come to the page. The “Save” button also becomes a “Reset” button.

Also, the SQL extension is bound to PL/SQL by default. Have you tried removing it from the list of extensions for the PL/SQL language in that same page, as explained in the documentation?

Does that help?