JVM restart disabled

SoanrQube version = 8.9.6 Enterprise edition
when trying to start our SonarQube services we are getting this error

wrapper | → Wrapper Started as Console
wrapper | Launching a JVM…
wrapper | The JVM process terminated due to an uncaught exception: EXCEPTION_ACCESS_VIOLATION (0xc0000005)
wrapper | JVM exited while loading the application.
wrapper | JVM Restarts disabled. Shutting down.
wrapper | ← Wrapper Stopped

Hi @amit.saurabh ,

i guess you are running SQ on windows right? already tried the usual (reboot, disable antivirus software, reinstall the application) ?
EXCEPTION_ACCESS_VIOLATION usually means an application tries to access memory it does not have access to. SQ should not do something like this usually :sweat_smile:

Hello,

Actually, this was handled on Commercial Support and the fix @amit.saurabh implemented was to provide the Java path in the wrapper configuration.
Though I agree @DefinitelyNotTobi, this is not a SQ thing, there was an issue with the JVM install and either this fix changed the JVM used, or a more simple operation helped (reboot, reinstall, etc.)

Cheers

1 Like

Hi @Antoine,

Thank You for your help and support!

Yes this issue is solved after we changed the Java path in the wrapper.conf file, But i was surprised about the issue that why this has happen. Because we haven’t done any change on our server. we just restarted our server in order to force reboot the SonarQube since there were long running job in our SonarQube environment. And suddenly this happen.

I suggest SonarQube should provide an option to SonarQube administrators to kill the long running job from portal it self so that such situations can be handled easily.

Regards,
Amit Saurabh