Jenkins build is sending the report to the wrong IP address


I am trying to build a project in jenkins using sonarqube. The build goes through but at the end of the scan the report is sent to a wrong IP address instead of the one that the server is hosted on.

Acutal Server IP
[test-project] $ /var/lib/jenkins/tools/hudson.plugins.sonar.SonarRunnerInstallation/sonar-scanner/bin/sonar-scanner ******** -Dsonar.projectKey=RingR_test_project_New -Dsonar.projectName=RingR_Test_New -Dsonar.core.serverBaseUrl= -Dsonar.sources=/var/lib/jenkins/workspace/test-project/webapp/frontend/ -Dsonar.projectBaseDir=/var/lib/jenkins/workspace/test-project

Analysis being reported to
INFO: Analysis report uploaded in 666ms
INFO: Note that you will be able to access the updated dashboard once the server has processed the submitted analysis report
INFO: More about the report processing at http://****sonar/api/ce/task?id=AW7wLMEs150A-TgQZDRS
INFO: Analysis total time: 33.491 s

The above IP address is wrong.
Don’t know whats the issue it was working fine for a while.

Please Help.

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this

I am using SonarQube Community Edition 7.8

Please have a look in the UI at the sonar.core.serverBaseUrl, this parameter is supposed to be set from here rather than from the command line.

Thanks for the help Alexandre. That worked.