Issue with SonarQube Upgrade from 4.2 to 4.4 on Ubuntu Latest with Cloudsmith Repository

Dear SonarQube Community,

I would like to share an issue I’ve encountered while upgrading SonarQube from version 4.2 to 4.4 on an Ubuntu latest system. The specific problem appears to arise when using a Cloudsmith repository and including credentials in the Gradle build script.

Here is a snippet of the Gradle build script causing the issue:

repositories {
    maven {
        name "dummy-cloudsmith"
        url "https://dl.dummy.io/basic/dummy-org/dummy-repo/maven/"
        credentials {
            username dummyCloudsmithUsername
            password dummyCloudsmithPassword
        }
    }
    mavenCentral()
}

On Ubuntu latest, this results in an error during the execution of the build script, identifying the line username dummyCloudsmithUsername as the culprit.

Interestingly, the same build script works without issues on Windows. This suggests that there might be a platform-specific problem when using Cloudsmith credentials in conjunction with SonarQube 4.4 on Ubuntu latest (Github Actions).

Has anyone else experienced similar issues or have suggestions for a possible solution? I appreciate any insights and assistance in identifying the cause and resolving this problem.

Thank you!

Hey there.

Thanks for the report.

What’s the specific error that you get?