"Insufficient privileges" when trying to save language settings

I have a private project within our organization that I use to analyze firmware code in C. Everything has worked fine so far.
Now I am trying to have Sonarcloud use my locally generated code coverage report. I am using gcovr to generate the report.
The report is included in my Bitbucket git repository.

Whenever I try to change the setting “Gcov reports” (in General Settings->Language->C / C++ / Objective-C) to include the path of my *.gcov file, I receive the error message: Validation failed. Insufficient privileges
I have tried to change other settings in this language and get the same error message with any other setting.
If I try to change a setting in one of the other settings categories, e.g. General or Analysis Scope, there is no error message and any changes are saved.

I am part of the Owner group in my organization, so I should have permissions to change any settings.

Are there advanced permissions that I need to change language settings? If yes, how can I get them?
Is there a bug related to changing language settings? Is it limited to my organization/project?

Thank you in advance for your help.


Hi Andreas,

And welcome to the community forum!

Thanks for reporting this, it’s a bug on our side, you should be able to change those settings with your owner permissions.
We found the root cause and a fix is in the pipe, you can follow our progress on this ticket : SCCOMM-12


Hi Grégoire,

Thanks for the quick response!

I saw that the bug is already marked as resolved. So thanks for the quick fix there as well.
When can I expect that fix to be deployed?


You can expect this fix to be deployed! We just deployed it in prod this instant.
I did a quick check on one of my project on sonarcloud.io and it was working fine so it should be the same for you!

Thanks again for the report and don’t hesitate to create a new post if you notice other bugs!