'Incomplete binding configuration' error when using SonarLint (vscode) locally

vscode

(Murat Ozcan) #1

I am trying out SonarLint and trying to promote it in my organization at Siemens Building Technologies.

These are my user settings in Vs Code.

I do not use a sonar server:

  • therefore I am expecting I am using the default/full ruleset.
  • I am expecting I do not need to set a serverId or projectey

What can be wrong? How can the warning be eliminated so that I know SonarLint is working properly.

image

User Settings in vsCode:

{
    "sonarlint.ls.javaHome": "C:\\Program Files\\Java\\jre1.8.0_171",
    "sonarlint.testFilePattern": "{**/test/**,**/*spec.ts,**/*spec.js}",
}

(Nicolas Bontoux) #2

Thanks for reaching out Murat. You’re hitting a known issue that is being taken care of as we speak:

  • SLVSCODE-40 - Bogus error popup during startup: Incomplete binding configuration

Fix is on its way, v1.3.1 should be out pretty soon.


(Janos Gyerik) #3

The fix is released. We combined it with other features and called it 1.4.0, skipping 1.3.1.