How to turn off "no-hardcoded-credentials" in sonar.project.properties

typescript

(A D) #1

I tried to create a tslint.json file with the following content:

{
“rules”: {
“no-hardcoded-credentials”: false
}
}

I also add this on my sonar.project.properties
sonar.ts.tslint.configPath = tslint.json

but it doesn’t work.

any help regarding this is so much appreciated.

thanks


(Elena Vilchik) #2

Please be more accurate about your problem and setup.

I’m not sure about your actual problem, but here are some points which might help you:

  • SonarQube does not care about tslint.json, and property sonar.ts.tslint.configPath belongs to a community plugin https://github.com/Pablissimo/SonarTsPlugin (I don’t know if you installed it)
  • You can disable SonarQube rules through profiles page.