Hi Team, I am newly installed SQ 7.9.1 with JDK11 on Linux EC2 Instance

I am newly installed SQ 7.9.1 with JDK11 on Linux EC2 Instance with Private IP address

  • SQ 7.9.1 with JDK11
  • logs are attached
  • 1.Installed JDK11
    2.Installed Sonarqube 7.9.1 , Unzipped and tried to run sonar from SONAR_HOME/bin/linux-x86-64/./sonar start

once started i am trying to hit the URL , http://myprivateip:9000

I don’t get the sonar home page , tried restart ec2, sonar, still same issue.
i tried to give my private ip in sonar.web.host=1.2.3.4 ,but no luck.

Isonar_logs.txt (33.7 KB)
am trying to achieve the sonar homepage with my private IP.

Note :(i am trying this within my VPN access)

Hi,

Welcome to the community!

The version you’ve installed is past EOL. You should install either the latest version - 9.1 - or the current LTS - 8.9.3 - instead.

Once you’ve installed a current version, you’ll want to start by trying a localhost request from the machine hosting SonarQube. You can diagnose further from there.

 
Ann

Ann, I have installed the latest version 9.1 from the source https://binaries.sonarsource.com/Distribution/sonarqube/sonarqube-9.1.0.47736.zip

I tried to start the sonar and hit localhost it says Not Found
i tried with IP and Port but still not able to get the sonarqube page,

## Not Found
HTTP Error 404. The requested resource is not found.

Below is the startup log.

sonar    26404     1  0 07:29 ?        00:00:00 /opt/sonarqube-9.1.0.47736/bin/linux-x86-64/./wrapper /opt/sonarqube-9.1.0.47736/bin/linux-x86-64/../../conf/wrapper.conf wrapper.syslog.ident=SonarQube wrapper.pidfile=/opt/sonarqube-9.1.0.47736/bin/linux-x86-64/./SonarQube.pid wrapper.daemonize=TRUE
sonar    26406 26404  1 07:29 ?        00:00:04 java -Dsonar.wrapped=true -Djava.awt.headless=true --add-exports=java.base/jdk.internal.ref=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/sun.nio.ch=ALL-UNNAMED --add-opens=java.management/sun.management=ALL-UNNAMED --add-opens=jdk.management/com.sun.management.internal=ALL-UNNAMED -Xms8m -Xmx32m -Djava.library.path=./lib -classpath ../../lib/sonar-application-9.1.0.47736.jar:../../lib/jsw/wrapper-3.2.3.jar:../../lib/sonar-shutdowner-9.1.0.47736.jar -Dwrapper.key=VCZEWXm7XfivCteQ -Dwrapper.port=32000 -Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999 -Dwrapper.pid=26404 -Dwrapper.version=3.2.3 -Dwrapper.native_library=wrapper -Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1 org.tanukisoftware.wrapper.WrapperSimpleApp org.sonar.application.App
sonar    26434 26406 10 07:29 ?        00:00:45 /usr/lib/jvm/jdk-11.0.1/bin/java -XX:+UseG1GC -Djava.io.tmpdir=/opt/sonarqube-9.1.0.47736/temp -XX:ErrorFile=../logs/es_hs_err_pid%p.log -Des.networkaddress.cache.ttl=60 -Des.networkaddress.cache.negative.ttl=10 -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -XX:-OmitStackTraceInFastThrow -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dio.netty.allocator.numDirectArenas=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Djava.locale.providers=COMPAT -Xmx512m -Xms512m -XX:MaxDirectMemorySize=256m -XX:+HeapDumpOnOutOfMemoryError -Des.path.home=/opt/sonarqube-9.1.0.47736/elasticsearch -Des.path.conf=/opt/sonarqube-9.1.0.47736/temp/conf/es -Des.distribution.flavor=default -Des.distribution.type=tar -Des.bundled_jdk=false -cp /opt/sonarqube-9.1.0.47736/elasticsearch/lib/* org.elasticsearch.bootstrap.Elasticsearch
sonar    26522 26406 13 07:29 ?        00:01:01 /usr/lib/jvm/jdk-11.0.1/bin/java -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djava.io.tmpdir=/opt/sonarqube-9.1.0.47736/temp -XX:-OmitStackTraceInFastThrow --add-opens=java.base/java.util=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED --add-exports=java.base/jdk.internal.ref=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/sun.nio.ch=ALL-UNNAMED --add-opens=java.management/sun.management=ALL-UNNAMED --add-opens=jdk.management/com.sun.management.internal=ALL-UNNAMED -Xmx512m -Xms128m -XX:+HeapDumpOnOutOfMemoryError -Dhttp.nonProxyHosts=localhost|127.*|[::1] -cp ./lib/sonar-application-9.1.0.47736.jar:/opt/sonarqube-9.1.0.47736/lib/jdbc/h2/h2-1.4.199.jar org.sonar.server.app.WebServer /opt/sonarqube-9.1.0.47736/temp/sq-process12929765480873925409properties
sonar    26651 26406  2 07:30 ?        00:00:10 /usr/lib/jvm/jdk-11.0.1/bin/java -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djava.io.tmpdir=/opt/sonarqube-9.1.0.47736/temp -XX:-OmitStackTraceInFastThrow --add-opens=java.base/java.util=ALL-UNNAMED --add-exports=java.base/jdk.internal.ref=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.nio=ALL-UNNAMED --add-opens=java.base/sun.nio.ch=ALL-UNNAMED --add-opens=java.management/sun.management=ALL-UNNAMED --add-opens=jdk.management/com.sun.management.internal=ALL-UNNAMED -Xmx512m -Xms128m -XX:+HeapDumpOnOutOfMemoryError -Dhttp.nonProxyHosts=localhost|127.*|[::1] -cp ./lib/sonar-application-9.1.0.47736.jar:/opt/sonarqube-9.1.0.47736/lib/jdbc/h2/h2-1.4.199.jar org.sonar.ce.app.CeServer /opt/sonarqube-9.1.0.47736/temp/sq-process14907928711996065999properties

Hi,

If you’re getting a 404 back, that means there’s a web server up and listening. What URL did you try, exactly?

 
Ann

I tried http://localhost/ and http://localhost:9000/

Also tried http://myip:9000/

And all three of those were 404?

Did you customize the sonar.web.context in $SONARQUBE-HOME/conf/sonar.properties?

 
Ann

only http://localhost/ is 404 Not found
I did not change sonar.web.context in $SONARQUBE-HOME/conf/sonar.properties

So if only one of the three was 404, that means the others were successful?

No, others says " This site can’t be reached"
I also tried adding “sonar.web.context=/sonar” in $SONARQUBE-HOME/conf/sonar.properties but no luck.

attached the logs.sonarqube_logs.txt (15.8 KB)

Hi,

Your logs indicate that SonarQube started just fine. Since you didn’t change the context, and presumably not the default port(?) it should be available at localhost:9000. I’m not sure what to tell you from there.

 
Ann

As you know i am trying out this in Private IP , is there any additional config for this to work.

Also ,could you advise how and what is the best way to upgrade sonarqube from 6.5 to the latest one.