Helm3.7 installation to Ubuntu/microk8s not working

hi, I’m trying to install sonarqube-lts 1.0.31+449 · sonarsource/sonarqube (so lts v8.9, but this also fails using bleeding edge v9 from same source).

k version --short
Client Version: v1.25.4
Kustomize Version: v4.5.7
Server Version: v1.25.4

k get pods -A
sonarqube            sonarqube-lts-postgresql-0                    1/1     Running                 0             8m2s
sonarqube            sonarqube-lts-sonarqube-lts-0                 0/1     Init:CrashLoopBackOff   6 (88s ago)   8m2s

k logs sonarqube-lts-sonarqube-lts-0 -n sonarqube
Defaulted container "sonarqube-lts" out of: sonarqube-lts, wait-for-db (init), init-sysctl (init), inject-prometheus-exporter (init)
Error from server (BadRequest): container "sonarqube-lts" in pod "sonarqube-lts-sonarqube-lts-0" is 
waiting to start: PodInitializing

similarly with sonarqube 7.0.0+449 · sonarsource/sonarqube which supports “Compatible Kubernetes Versions: From 1.19 to 1.25”
I end up with:

k get pods -n sonarqube
NAME                     READY   STATUS       RESTARTS      AGE
sonarqube-postgresql-0   1/1     Running      0             55s
sonarqube-sonarqube-0    0/1     Init:Error   2 (29s ago)   55s

k logs sonarqube-sonarqube-0 -n sonarqube
Defaulted container "sonarqube" out of: sonarqube, wait-for-db (init), init-sysctl (init), inject- prometheus-exporter (init)
Error from server (BadRequest): container "sonarqube" in pod "sonarqube-sonarqube-0" is waiting  to start: PodInitializing

any ideas? my microk8s installation is new and running on Ubuntu 22.04.1 LTS
thanks

Hi,

Do you have any logging that might help? Server logging or otherwise?

 
Ann