Helm Upgrade Doesn't Pick the changes from Values.yaml

Must-share information (formatted with Markdown):

  • which versions are you using - 9.9 Enterprise
  • how is SonarQube deployed - Helm
  • what are you trying to achieve - Upgrade
  • what have you tried so far to achieve this - I have tried
    helm upgrade --install sonarqube-ent ./
    helm upgrade --install --values values.yaml sonarqube-ent ./
    Changes made in values.yaml are:
    image:repository:location of image in google artifact registry
    jdbcOverwrite:jdbcUrl: “jdbc:postgresql:someip:5432/databsename

I have tried a lot more options but helm doesn’t pick the updated values from values.yaml. SonarQube is running after I made change in deployment file with the new image repository location. But It is still connecting to the old database.

Hey there.

Are you also setting jdbcOverwrite:enable: true?

## Override JDBC values
## for external Databases
  # If enable the JDBC Overwrite, make sure to set `postgresql.enabled=false`
  enable: false
  # The JDBC url of the external DB
  jdbcUrl: "jdbc:postgresql://myPostgress/myDatabase?socketTimeout=1500"
  # The DB user that should be used for the JDBC connection
  jdbcUsername: "sonarUser"
  # Use this if you don't mind the DB password getting stored in plain text within the values file
  jdbcPassword: "sonarPass"
  ## Alternatively, use a pre-existing k8s secret containing the DB password
  # jdbcSecretName: "sonarqube-jdbc"
  ## and the secretValueKey of the password found within that secret
  # jdbcSecretPasswordKey: "jdbc-password"

Can you also confirm what version of the Helm chart you’re using?