Failure during analysis, Node.js command to start eslint-bridge server was not built yet

Template for a good bug report, formatted with Markdown:

  • Versions used (SonarQube, Scanner, Plugin, and any relevant extension)
  • SonarQube:, 8.9.7, 8.9.3
  • Scanner:,,
  • Error observed (wrap logs/code around triple quote ``` for proper formatting)
18:36:29.303 DEBUG: Deploying bundle
18:36:29.311 DEBUG: Deploying eslint-bridge into /usr/src/.scannerwork/.sonartmp/eslint-bridge-bundle
18:36:34.651 ERROR: Failure during analysis, Node.js command to start eslint-bridge server was not built yet. Corrupt GZIP trailer
	at java.base/
	at java.base/
	at java.base/
	at org.apache.commons.compress.utils.IOUtils.skip(
	at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.consumeRemainderOfLastBlock(
	at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.getRecord(
	at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.getNextTarEntry(
	at org.apache.commons.compress.archivers.tar.TarArchiveInputStream.getNextEntry(
	at org.sonar.plugins.javascript.eslint.BundleUtils.extractFromClasspath(
	at org.sonar.plugins.javascript.eslint.BundleImpl.deploy(
	at org.sonar.plugins.javascript.eslint.EslintBridgeServerImpl.deploy(
	at org.sonar.plugins.javascript.eslint.EslintBridgeServerImpl.startServerLazily(
	at org.sonar.plugins.javascript.eslint.AbstractEslintSensor.execute(
	at org.sonar.plugins.javascript.eslint.CssRuleSensor.execute(
	at org.sonar.scanner.sensor.AbstractSensorWrapper.analyse(
	at org.sonar.scanner.sensor.ModuleSensorsExecutor.execute(
	at org.sonar.scanner.sensor.ModuleSensorsExecutor.lambda$execute$1(
	at org.sonar.scanner.sensor.ModuleSensorsExecutor.withModuleStrategy(
	at org.sonar.scanner.sensor.ModuleSensorsExecutor.execute(
	at org.sonar.scanner.scan.ModuleScanContainer.doAfterStart(
	at org.sonar.core.platform.ComponentContainer.startComponents(
	at org.sonar.core.platform.ComponentContainer.execute(
	at org.sonar.scanner.scan.ProjectScanContainer.scan(
	at org.sonar.scanner.scan.ProjectScanContainer.scanRecursively(
	at org.sonar.scanner.scan.ProjectScanContainer.doAfterStart(
	at org.sonar.core.platform.ComponentContainer.startComponents(
	at org.sonar.core.platform.ComponentContainer.execute(
	at org.sonar.scanner.bootstrap.GlobalContainer.doAfterStart(
	at org.sonar.core.platform.ComponentContainer.startComponents(
	at org.sonar.core.platform.ComponentContainer.execute(
	at org.sonar.batch.bootstrapper.Batch.doExecute(
	at org.sonar.batch.bootstrapper.Batch.execute(
	at org.sonarsource.scanner.api.internal.batch.BatchIsolatedLauncher.execute(
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(
	at java.base/java.lang.reflect.Method.invoke(
	at org.sonarsource.scanner.api.internal.IsolatedLauncherProxy.invoke(
	at com.sun.proxy.$Proxy0.execute(Unknown Source)
	at org.sonarsource.scanner.api.EmbeddedScanner.doExecute(
	at org.sonarsource.scanner.api.EmbeddedScanner.execute(
	at org.sonarsource.scanner.cli.Main.execute(
	at org.sonarsource.scanner.cli.Main.execute(
	at org.sonarsource.scanner.cli.Main.main(
  • Steps to reproduce
  • Run PHP analysis via Jenkins
  • Potential workaround
  • I have tried everything I could think off. Upgrading/downgrading Sonar, Sonarqube-cli, moved my analysis into a docker container to ensure no dependencies on my Jenkins server were causing the issue, increased the memory of my Jenkins server, deleted all plugins on the Sonar server.
  • Scanner command used when applicable (private details masked)
            withSonarQubeEnv(installationName: 'Sonar', credentialsId: 'Sonar') {
              sh 'sonar/bin/sonar-scanner'
docker run --rm -e SONAR_HOST_URL="${SONAR_HOST_URL}" -e SONAR_LOGIN="${SONAR_AUTH_TOKEN}" -v "${WORKSPACE}:/usr/src" sonarsource/sonar-scanner-cli

oh, and the analysis seems to complete correctly…

21:36:01.714 DEBUG: POST 200 | time=363ms
21:36:01.720 INFO: Analysis report uploaded in 369ms
21:36:01.721 DEBUG: Report metadata written to /var/lib/jenkins/workspace/..../.scannerwork/report-task.txt
21:36:01.721 INFO: ANALYSIS SUCCESSFUL, you can browse https://sonar.,,,,.com/dashboard?id=....
21:36:01.721 INFO: Note that you will be able to access the updated dashboard once the server has processed the submitted analysis report
21:36:01.721 INFO: More about the report processing at
21:36:01.725 DEBUG: Post-jobs :
21:36:02.799 INFO: Analysis total time: 1:49.086 s
21:36:02.802 INFO: ------------------------------------------------------------------------
21:36:02.802 INFO: ------------------------------------------------------------------------
21:36:02.803 INFO: Total time: 1:54.216s
21:36:02.889 INFO: Final Memory: 17M/102M
21:36:02.889 INFO: ------------------------------------------------------------------------

but then on the server, the background task is ‘failed’ with the following error:

java.lang.IllegalStateException: Fail to extract report AX_2E7drk4xl5rrXvW5e from database
	at org.sonar.ce.task.projectanalysis.step.ExtractReportStep.execute(
	at org.sonar.ce.task.step.ComputationStepExecutor.executeStep(
	at org.sonar.ce.task.step.ComputationStepExecutor.executeSteps(
	at org.sonar.ce.task.step.ComputationStepExecutor.execute(
	at org.sonar.ce.task.projectanalysis.taskprocessor.ReportTaskProcessor.process(
	at org.sonar.ce.taskprocessor.CeWorkerImpl$ExecuteTask.executeTask(
	at org.sonar.ce.taskprocessor.CeWorkerImpl$
	at org.sonar.ce.taskprocessor.CeWorkerImpl.findAndProcessTask(
	at org.sonar.ce.taskprocessor.CeWorkerImpl$TrackRunningState.get(
	at java.base/java.util.concurrent.Executors$
	at java.base/
	at java.base/java.util.concurrent.ScheduledThreadPoolExecutor$
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/
Caused by: invalid entry CRC (expected 0x3387d439 but got 0x5481b075)
	at java.base/
	at java.base/
	at java.base/
	at org.sonar.api.utils.ZipUtils.copy(
	at org.sonar.api.utils.ZipUtils.unzipEntry(
	at org.sonar.api.utils.ZipUtils.unzip(
	at org.sonar.api.utils.ZipUtils.unzip(
	at org.sonar.ce.task.projectanalysis.step.ExtractReportStep.execute(
	... 19 more


Welcome to the community!

Thanks for the follow-up post. With it, it looks like there’s something interfering with the transmission of zip files to/from analysis…? Do you maybe have a “helpful” proxy between analysis and your SonarQube server?


Any luck with this? I am getting the same issue with server 8.9 LTS and scanner 4.7.

Trying to scan a typescript project and the ts/tsx files are ignored. Only CSS and HTML are scanned.

Hi @kxt5258,

Welcome to the community!

If you’re actually getting an analysis, then it’s probably not the same problem. Could you create a new thread, please?


Sure @ganncamp , will do. However, I feel it is the same issue. Looks like an issue with the docker image.

There is a Traefik server in between the server running the analysis and the server (docker) that’s running Sonar, but that has been there for about a year without problems.

Also, I’ve done some more testing and found a combination that does work:
I’m now running on the server and sonarsource/sonar-scanner-cli:4.6 ( on docker) for analysis. This docker runs on a different machine then the server, so the Traefik proxy is still in between. Oddly enough, if I switch to outside of docker, running straight on the Linux machine, the problem is back, but if I switch to a newer version on docker, I also get the issue back.


While I still suspect interference, we’ve seen something similar once before but weren’t able to get to the root of it, so I’ve flagged this for more expert attention.

And I want to point out that you’re on neither the latest version of SQ nor the scanner.

And it might be useful to try a different Java distro in the meantime.


Hey guys, @Jeroen @ganncamp

I’m facing this issue, too.
I checked it, due to docker image latest of sonarsource.

How to resolve?
Please change docker image from sonarsource/sonar-scanner-cli:latest => sonarsource/sonar-scanner-cli:4.6

Later, if docker image of sonarsource is Ok, we can change back.

1 Like

Please change docker image from sonarsource/sonar-scanner-cli: latest => sonarsource/sonar-scanner-cli: 4.6
It will works.

@Colin @ganncamp Please close this topic and mark answer as resolved.

@Colin @ganncamp Please close this topic and mark answer as resolved.

First of all, you didn’t open the topic. Secondly, falling back to a year old version is NOT a solution.

From my attempts from fixing the same ZipException in our installation it seems to have a relation to the report size.
The ZipException only occured in one of our projects main branch analysis (report size ~30MB) while other projects main branch analysis (report size ~3MB) worked perfectly fine with the lastest 4.7 SonarScanner. The projects are identical in set up and configuration.

Reverting to the 4.6 does work as already found.


Hey @Jeroen @thachnv92 @SteveSi

See this update here: