Failing auto-scan

The last analysis has failed. If it keeps on failing after several attempts, please contact us on Community forum and provide the following failing analysis ID: “5296cde2-4f49-4e9d-9f8b-cc24c9ae458d”.

I also couldn’t find a setting item to configure sonar.sources

I created a file and added sonar.sources there but

provide the following failing analysis ID: “AXJisRmHydHY5J0JNbrq”.

latest one
provide the following failing analysis ID: “AXJixqDvkBPNmCr6PHYH”.
if I run


INFO: Analysis total time: 12:16.248 s
INFO: ------------------------------------------------------------------------
INFO: ------------------------------------------------------------------------
INFO: Total time: 12:20.413s
INFO: Final Memory: 32M/117M

Hello @aradhell,

It seems that the scanner runs out of memory when scanning your sources. I can see that it is scanning files under the /libraries folder, which is typically not what you want to do.

You can exclude these files from the analysis by navigating to Administration > General Setting > Analysis Scope > Source File Exclusions on your project on SonarCloud and adding /libraries/**/*

Hi @TomVanBraband
I already have



Hello @aradhell,

I’m sorry, I was too quick in replying to your post.

In the original post you mentioned that you added sonar.sources in a file, but in your latest comment you mention a file. Only the second way of configuring parameters is supported for Automatic Analysis. Can you confirm this is the case?

Setting the sonar.inclusions property through the UI to includes should also fix your issue.

Hi Tom yes I added to default branch