Failed to set JVM input handle to non blocking mode

I installed sonarqube with brew.

When I run brew services start sonarqube, I get a message Successfully started sonarqube (label: homebrew.mxcl.sonarqube) but I can’t run it on localhost:9000

Versions:
SonarQube 9.5.0.56709

sonar-scanner --verion
SonarScanner 4.7.0.2747
java --version
openjdk 11.0.12 2021-07-20
OpenJDK Runtime Environment Temurin-11.0.12+7 (build 11.0.12+7)
OpenJDK 64-Bit Server VM Temurin-11.0.12+7 (build 11.0.12+7, mixed mode)

Logs:

Launching a JVM...
Failed to set JVM input handle to non blocking mode: Bad file descriptor (9)
Failed to set JVM input handle to close on JVM exit: Bad file descriptor (9)
JVM exited while loading the application.
Unable to set JVM's stdin: Bad file descriptor
wrapper  | --> Wrapper Started as Console
wrapper  | Java Service Wrapper Community Edition 64-bit 3.5.50
wrapper  |   Copyright (C) 1999-2022 Tanuki Software, Ltd. All Rights Reserved.
wrapper  |     http://wrapper.tanukisoftware.com
wrapper  | 
wrapper  | Launching a JVM...
Automatic JVM Restarts disabled.  Shutting down.
<-- Wrapper Stopped

I updated the path in wrapper.conf to:

wrapper.java.command=/Library/Java/JavaVirtualMachines/temurin-11.jdk/Contents/Home/bin/java

But I still get the same message. What should I fix?

Hey there.

As this formula is not created by SonarSource, you should raise an issue with the maintainer. It embeds a version of the Java Service Wrapper that we don’t (and cannot, due to license limitations), so there’s no help we can provide :confused: