Error when making api call

Using sonarqube community edition 8.9 and java 8.
When I tried to make api call to server using zero trust, I am facing an error: socketgaierror: nodename nor servername not provided but when tried with vpn it is working completely fine. Is there any configuration that I have to change or any other steps I am missing?

Note: Other server inside the same domain where sonarqube server is located are working completely fine with both zero trust and vpn.

Hey there.

To be honest, I’m not sure what ZeroTrust is. It’s probably a good question for whoever supports that.

And, your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.9 → 9.9.2 → 10.2 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

Upgrading the sonarqube community to latest edition is not allowing me to use java 8. Is there an updated version to support java 8, if so please let us know.

You can support Java 8 on all currently supported versions of SonarQube – you just may need to switch to using Java 11 or Java 17 to run the scanner. Take a look at the documentation on Scanner environment.