Error using Azure Devops Extension

Must-share information (formatted with Markdown):

  • which versions are you using 8.9.2.46101
  • how is SonarQube deployed: zip
  • Analisys from Azure Devops

Today I am getting an error while trying to analize code using the Azure Devops Plugin
The error I get is:
##[error]java.lang.UnsupportedClassVersionError: org/sonarsource/scanner/cli/Main has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0

I noticed the Azure Devops plugin has been updated today at version 5.19.1

I don’t know if it is relevant, but I am using openjdk 17 on the server for analysis.
The analysis made before (some pipeline) ended with no error

My fault.
JAVA_HOME was still on java8.
Updated to use openjdk17 and now works.

1 Like