Error probing compiler cl2000

Hello Massimo,
I am facing the same problem. So I try to change silicon_version=28.
How do I change the version?
sonar-scanner.bat -D"sonar.projectKey=current_ratio2" -D"sonar.sources=." -D"sonar.cfamily.build-wrapper-output=bw-output" -D"sonar.host.url=http://localhost:9000" -D"sonar.login=f17bb4cf028f05f1042c9af6c31c4c40c86acf30" -D"silicon_version=28"
Is this command right or not? please advice me to fix it.

Hi @K2H,

could you please share what version of SonarQube you are using the the sonar-scanner log?

No, this is not the way to set silicon_version=28.

Hi Massimo,

This is sonarqube version what I am using. please check and help me to cleare this issue.
Sonarqube: 9.3.0.51899
Sonar-scanner: 4.7.0.2747
sonar-scanner-error_log.txt (84.6 KB)

Hi @K2H ,

would you also be able to share bw-output\build-wrapper-dump.json file?

Hi Massimo,

This is json file. please check it. thanks.
build-wrapper-dump.json (325.4 KB)
Is it possible to solve or avoid this issue?

Hi @K2H ,

sorry for the delay. In your compiler calls you have -v28 option, could you replace it by --silicon_version=28 arguments or use a newer version of cl2000 compiler?

Thank you for your reply.

I want you ask about how to replace by --silicon_version=28. I am sorry that I don’t know how should I replace it.
This is my compiler option, and I am uisng target version 28. (is this incorrect?)

I can change the compiler version, but there is a difficulty because I am already mass-producing it.
First of all, sonarqube is doing it through the upper version compiler and considering using the lower version when using it for internal products.
But that would be very inconvenient. If possible, I would appreciate it if you could tell me how to do it.

Hi @K2H ,

could you try a test to validate that it would solve the issue? Could you replace -v28 with --silicon_version=28 in the build-wrapper-dump.json?

Hi,

I don’t know how to change silicon_version to 28. please let me know correct command. thanks.