Error in SonarLint for IntelliJ - macOS - Apple Silicon

Environment:

  • Java: JetBrains s.r.o. 11.0.11
  • OS: Mac OS X x86_64
  • IDE: JetBrains Rider 2021.2
  • SonarLint: 5.2.0.35150
c.ij.serviceContainer.AlreadyDisposedException: Cannot create ServiceAdapter(descriptor=ServiceDescriptor(interface='null', serviceImplementation='com.jetbrains.rider.editors.RiderBackendInteractionHelper', testServiceImplementation='null', headlessImplementation='null', overrides=false, configurationSchemaKey='null', preload=FALSE, client=null), pluginDescriptor=PluginDescriptor(name=IDEA CORE, id=com.intellij, descriptorPath=plugin.xml, path=~/Library/Application Support/JetBrains/Toolbox/apps/Rider/ch-0/212.4746.113/Rider.app/Contents, version=212.4746.113, package=null)) because container is already disposed (container=Project(name=Akka, containerState=DISPOSED, componentStore=/Users/andyfurnival/GIT/akka.net/src) (disposed))
	at c.ij.serviceContainer.ContainerUtilKt.throwAlreadyDisposedError(containerUtil.kt:125)
	at c.ij.serviceContainer.BaseComponentAdapter.checkContainerIsActive(BaseComponentAdapter.kt:139)
	at c.ij.serviceContainer.BaseComponentAdapter.getInstanceUncached(BaseComponentAdapter.kt:72)
	at c.ij.serviceContainer.BaseComponentAdapter.getInstance(BaseComponentAdapter.kt:67)
	at c.ij.serviceContainer.BaseComponentAdapter.getInstance$default(BaseComponentAdapter.kt:60)
	at c.ij.serviceContainer.ComponentManagerImpl.doGetService(ComponentManagerImpl.kt:590)
	at c.ij.serviceContainer.ComponentManagerImpl.getService(ComponentManagerImpl.kt:573)

Hello Andyfurnival,

Welcome to the community and thanks for your feedback!
Unfortunately this stack trace looks truncated and it’s difficult to understand what causes the problem. Would be great to get more full trace if possible. Anyway we will try to investigate it.
Have a good day!

Hi Kirill,

Does the SonarLint plugin store logs anywhere by default? I’ve had a look, and I can’t see any. This stack trace was all handled by the plugin from what I could tell, maybe that’s a problem in itself?

I’ve opened the same workspace, I’ve not connected it to Sonarcloud, but its not thrown any more errors that I can tell (unless they get suppressed by Rider)

Thanks
Andy

Hi @andyfurnival,

Sorry answer took so long.
In SonarLint tool window press on gear icon on the right side and make sure Analysis logs and Verbose output checkboxes are marked.


That will give you the most full logs.