Error during scanning through Azure Pipelines

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube - 8.3 Enterprise, scanner-4.10 )
  • what are you trying to achieve - run analysis of a python code
  • what have you tried so far to achieve this -

Tried to trigger analysis in sonarqube enterprise instance via Azure pipelines. I have proper permissions in the instance and I am able to scan other projects too. For a specific project I get the error -

16:37:33.100 INFO: Analysis report generated in 14158ms, dir size=66 MB
16:38:20.976 INFO: Analysis report compressed in 47876ms, zip size=22 MB
16:38:20.976 INFO: Analysis report generated in xxxxxxx\scanner-report
16:38:20.976 DEBUG: Upload report
16:38:22.196 DEBUG: POST 403 https://xxxxxxxxxx | time=1219ms
16:38:22.209 INFO: ------------------------------------------------------------------------
16:38:22.209 INFO: EXECUTION FAILURE
16:38:22.209 INFO: ------------------------------------------------------------------------
16:38:22.209 INFO: Total time: 15:08.493s
16:38:22.504 INFO: Final Memory: 77M/1599M
16:38:22.504 INFO: ------------------------------------------------------------------------
##[error]16:38:22.504 ERROR: Error during SonarScanner execution

Hi,

Your error is that you’re not authorized to run analysis. You’ll need to pass in to analysis the auth token of a user with analysis permissions on the project. Looks like that gets set up when you configure your service endpoint.

 
HTH,
Ann