Configuration of Priority - SonarLint - Hover on Mouseover

Hi there,

I am using the eclipse sonarlint plugin and would like to ask where i can “switch off” the sonarlint Popup (Hover) so that my “normal” UX is restored even though the “squiggly lines” get displayed. So i do not want to switch off sonarlint-functionality alltogether, but rather remove the popups.

i just had the experience that i wanted to see the Hover (Mouseover - Tooltip Popup) i was expecting from eclipse but instead i only got to see the sonarlint problemdescription.

I would have expected this to be available under Menu.

Window --> Preferences --> Java --> Editor --> Content Assist --> Hovers

Cheers
Daniel

//edit1: added tag sonarlint // edit2: added this comment :slight_smile:

Hi Daniel,

I don’t think it is possible to remove the tooltip while keeping the "squiggly lines”.

Would you mind sharing more details about what is the problem for you with those tooltips?

Sure thing, Julien. I am having a hard time seeing the stuff that would be displayed if the SonarLint-Tooltip were not to pop up. That is what i ment, when i wrote:

I would like to have the Hover (Tooltip) configurable like the other hovers, if that might be possible. So that i could put it on a dedicated Modifier Key for example. At least that is what i think might be helpful, if possible.

Feel free to keep asking in case that my description isnt descriptive enough :thinking:

SonarLint markers are using standard Eclipse problems framework.

The tooltip is displayed because of the Combined Hover. You can maybe add a key modifier to “Problem Description” in order to not have it by default?

Thank you for thinking about this one. I had a specific case in mind when i wrote the first posting. I currently do not have that case at hand / cannot recall it. So instead i played around with the settings and what worked for me as a quick workaround was to:

  • disable the “Combined Hover”
  • activate the “Problem description” and adding a Modifier Key to it

I somehow do not have a good gut feeling about that (the need to disable the default behaviour) , but for a quick solution that seems to work.

I will comeback to this posting (and mention you then, too, probably) when i find my original problem not yet solved or i have further opinions relating to this. In the mean time … thank you for trying to find a solution and working on this in your brain! :slight_smile:

cheers,
Daniel