Change sonarqube work path from /

I have a GKE cluster with deployed SonarQube.
Also, we added istio, and changed the work path from http://IP_ADDRESS to http://IP_ADDRESS/sonarqube/.

Now we get an error, because sonarqube tries to find general files in http://IP_ADDRESS, but should check in http://IP_ADDRESS/sonarqube/.

We use https://github.com/helm/charts/tree/master/stable/sonarqube for deployment.
How can I change the work path, which value should I change?
Please help.

Welcome to the community. You mean you added istio, to use it as a reverse proxy ?

Hello Pierre!
Yes, we added Istio as a proxy.

Yup so i’m sorry but i won’t be able to help you with that, as we do not use it internally. I guess this is a common question in the istio world, so you should try to get help on the helm chart (that is not supported by sonarsource, this is purely community developed), and on the istio community.

Also, you should check that the “Server base URL” setting correctly contains “/sonarqube”

Well, I think that my question mostly about changing the work path.
Let’s skip istio.
How can I change work path from / to /sonarqube/ ?
Should I set something like sonar.host.url or Server_Base_URL, etc.?

You need to do 2 things :

  1. Set sonar.web.context=/sonarqube in conf/sonar.properties file
  2. Update “Server base URL” setting in Administration > Configuration > General Settings UI

Added:
livenessProbe:
sonarWebContext: /sonarqube/
readinessProbe:
sonarWebContext: /sonarqube/
extraEnv:
sonar.web.context: /sonarqube

Now it works.

Thanks @Oleksandr_Sh for explaining how you’ve fixed your issue

1 Like

Hi Oleksandr,

I have installed the Sonarqube in AKS with helm chart and have updated the values for the ingress and sonarwebcontext path. When i am trying to access the sonarqube URL its failing with page is loading. Please help me on the issue, where need to update values apart you mentioned. Thank you.

Regards,
Sreedhar

There are two parts of this issue, we are using istio as ingress, and apart of sonarqube configuration, I’ve also configured ingress gateway to route traffic from /path to kubernetes service local dns. You might need to check your ingress logs. Also, you may search some configuration in the internet. My problem was mostly related to istio, and I don’t see many examples so far. If you use nginx or something similar, there should be an example.

Whats the sonarwebcontext path you have given, for me when i try to open the URL, it shows as “Loading”