Can't stop sonar on OSX

We are currently using SonarQube 5.6.3 and we just bought a licence for a developer edition. From what I understood, I need first to upgrade our SonarQube instance prior to activate that licence.

So I downloaded version 6.7.6, installed it, updated the config file, and made a backup of the database.
Now I am trying to stop the 5.6.3 and I tried everything (kill in activity monitor, restart the mac, use the “stop” subcommand of the shell script), the instance always restart itself :frowning:

This issue seems to prevent me from starting the 6.7.6 and launch the upgrade, because the old version keeps some port bound (for instance elasticsearch seems to fail starting because port is already bound…)

Here is the output of a “ps aux | grep ‘Sonar’” :

/Users/../Desktop/sonar/sonarqube-5.6.3/bin/macosx-universal-64/./wrapper /Users/.../Desktop/sonar/sonarqube-5.6.3/bin/macosx-universal-64/../../conf/wrapper.conf wrapper.syslog.ident=SonarQube wrapper.pidfile=/Users/.../Desktop/sonar/sonarqube-5.6.3/bin/macosx-universal-64/./ wrapper.daemonize=TRUE

I also tried to change that wrapper.daemonize to FALSE in the .sh script directly, but this has no effect, and I still don’t know how this instance is able to restart itself.

Wrong. You should first upgrade to 5.6.7, and next to 6.7.6.