Build Wrapper not Populating build-wrapper-dump.json using wrenv

Command used: c:/windriver70/wrenv.exe -p vxworks-7 c:\SonarScanner\build-wrapper-win-x86\build-wrapper-win-x86-64.exe --out-dir c:/Scan make
Language: C++ make, WindRiver Workbench, vxworks

After running the command, the build-wrapper-dump.json file does not get populated. The build completes, but the build-wrapper logs have multiple instances of skipping process which we think may be causing the file to not get populated. We have run the command above in a variety of different ways including doing a make clean

Posted an earlier topic about this issue here: Build Wrapper not populating build-wrapper-dump.json

It was encouraging to see the topic generated an issue and there was work done to try and fix this in a later release. We tried the new version of the build wrapper with the fix and we still did not see any output to our build-wrapper-dump.json

build-wrapper-dump.json (518 Bytes)
build-wrapper.log (60.1 KB)

We are thinking the problem could be wrenv wrapping the command. Any help or suggestions to try and get some output would be greatly appreciated.

Thank you!

Hi,

From what I can tell, wrenv sets up the environment, and doesn’t actually need to be part of the build command.

Is it possible to do this?

c:/windriver70/wrenv.exe -p vxworks-7 
c:\SonarScanner\build-wrapper-win-x86\build-wrapper-win-x86-64.exe --out-dir c:/Scan make

 
Ann

I had not tried that after I got the new executable. That appears to have worked if I do it manually.

Wrenv takes an executable to run like this:
c:/windriver70/wrenv.exe -p vxworks-7
which runs a vxworks shell to build in.

My build-wrapper-dump.json now has about 5 megabytes in it, so I can now continue on. My first task will be to get this to run in a batch file , but now I know that is can be done.

The new wrpper executable is now working, thank you for the suggestion.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.