Build-wrapper generate permission denied in gitlab cicd

I am working with the version * Developer Edition

  • Version 9.5 to integrate sonarqube in my gitlab for a C project.
    download is okey. i got a problem when i try to do the build i got a permission denied like this:

$ .sonar/build-wrapper-linux-x86/build-wrapper-linux-x86-64 --out-dir .sonar/bw-output make clean all

.sonar/build-wrapper-linux-x86/build-wrapper-linux-x86-64: Permission denied

I try all the way to fixe permission denied on file.

If someone have a idea, can you help me please.


Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

9.5 → 9.9.1 → 10.1 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade, please come back to us.

1 Like

Thanks Colin.

i did a update of sonarqube. I am in the latest now: 10.2.

i still get the same issue.

if you have any other ideas please help

Thanks and welcome to the future! :smiley:

Have you tried a chmod +x on the build-wrapper executable?

I did it too before execution


What about a chmod +x specifically on .sonar/build-wrapper-linux-x86/build-wrapper-linux-x86-64?



I wonder if the error is from executing the build-wrapper itself or from an inability for the build-wrapper to create .sonar/bw-output? Can you try setting the output directory to something outside the .sonar directory (which is a working directory for the scanner to use & not really intended for you to write other things to)?