Background processes constantly pop up notification window in foreground

Please provide

  • Operating system: Windows
  • SonarLint plugin version:
  • IntelliJ IDEA 2022.3.1 Ultimate Edition
  • Programming language you’re coding in: Java
  • Is connected mode used:
    • Connected to SonarCloud or SonarQube (and which version):

And a thorough description of the problem / question:
Navigating to any Java file in IntelliJ causes a notification window to pop up in the foreground for anywhere from 1 to 8 seconds saying ‘Refreshing taint vulnerabilities…’

Serge Baranov replied:

If it occurs only for a plug-in, please report it to the plug-in developer so that they make the tasks run in background without a popup by default.

Hi @jonathan.gifford

We have already defined the refresh task to be on background by default:

I tried to reproduce your issue but could not (at least with 2022.3, I will try to upgrade to 2022.3.1 in case it makes a difference).

Thank you for looking into this so promptly Julien.

To be clear, I am not saying that the taint process is running in the foreground.

What is happening is that the notification window about the background tasks is popping up. It goes away once the process(es) are finished.

It’s as if the ‘Hide processes’ option gets turned off every time the plugin runs.

It’s possible of course that there is a generic IntelliJ setting that controls this, but I have not found anything in all my searches, and since the IntelliJ developer suggested the issue lies with the plug developer, I was hoping that there is something you could do.

When I disable the Sonarqube plugin, I do not see the issue. Upon startup the notification window will pop up temporarily for some longer-running background processes, but it does not pop up when navigating between files.



OK, can you try:

On my side, when “Auto Show” is selected, I observe the same behavior as you describe, but I think this is expected.

Thank you Julien, that was exactly the issue. I thought there might be a setting somewhere, but I didn’t look in actions.



1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.