Azure devops plugin fails to upload report

I am using Azure DevOps for my CI/CD and I try to upload analysis using a pipeline on Sonarcloud.

Azure DevOps extension version: 1.34.2 (Latest)

I am using a linux agent (ubuntu 20.04) with dotnet installed and I install the sonar tool using

dotnet tool install --global dotnet-sonarscanner --version 5.9.1

In the pipeline I first use prepare, then I build an application and the I try to upload the results.


The task is failing in the upload report procedure.


Although settings are correct as the debug logs seem that can fetch information from sonarcloud, when the report is uploading there is an issue.

We tried to escape the URL using ‘quotes’ but also this did not work as we had issues in previous steps of the analysis, when it fetches the branches and information about the project.


Any suggestions?

We have tried to run the analysis with dotnet-sonarscanner msbuild from a windows machine instead of a linux machine with sonar cli and we get the exact same error on the upload of the report.


Could this be a bug of the version?

Hey there.

Cut off screenshots of logs aren’t great debugging information. :slight_smile: Please share text-based logs in the future.

I’m having a bit of trouble understanding your build setup – can you share your Azure DevOps Pipeline YML?

We finally figured out that this error was due to upload results permissions missing on Sonarcloud project. The 404 error was very misleading for this particular case.