Avoid Stop using 'Sonar Way' in the Activity Side Panel

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    9.9 LTS Community Edition
  • how is SonarQube deployed: zip, Docker, Helm
  • what are you trying to achieve
  1. have a clean side panel of activity
  2. few custom fields reflected in the side panel. (e.g. tests, version, changeset, jenkinsurl)

These fields will also be refected in the graph on right side.

  • what have you tried so far to achieve this
    I have a custom sonar profile called ‘sonar_way_with_cxx_activated’ which is inherited from sonar way and a few additional rules activated from cxx plugin.
    I am passing in sonar.sources and sonar.cxx.bullseye.reportPaths and sonar.buildString.
    For additional fields, I tried -Dsonar.analysis.key=value but nothing is reflected in the ‘Activity’ Tab.


Welcome to the community!

Those side panel notes are “events”, and there’s no way to suppress them from display.

They’re created and displayed as a way to track a significant administrative change on your project. Changing Quality Profiles could drastically drop or increase your issue count. Without the notation that the Quality Profile changed at that point, you’d have no way of knowing why there was a big change in your analysis results.

Regarding your custom properties, sonar.analysis.key, they won’t be displayed in the left panel, but I believe are available on mouseover…?


They are not available on mouseover.

Infact, my “BuildString” is a long one and is terminate at approx 20chars. This too is not available on mouseover. Neither on the left panel and neither on the graph.

I am using community edition as mentioned above.

Any setting I need to configure to tackle either of these issues.


I’m not sure what version I was looking at when I told you the build string would be available as a mouseover, but I’ve just retested in 10.0, and it’s available in the UI: