Automatic scaning from github stalled

Scanning is lagging and stalled for all our repositories github automated analysis, it has been a blocker for development. I posted here but was told to place in an area with more visibility. It looks like it is the same issue mentioned in the thread.

https://community.sonarsource.com/t/automatic-analysis-slowdown-processing-github-prs/96466/3

Hi Erick!

We discovered some bugs with the reporting of the status of PR that are scanned by the Automatic Analysis and fail, they look like stuck in progress, and we are currently working on a fix.

Does it seem like the issue you are encountering? If you have some analysis passing and some that are stuck, it might be it.

yes we have been experiencing this since Aug 1.

Is there an update? we havent been able to scan for 2 weeks…

Hi,

The fix has been deployed. Can you please confirm that the issue has been resolved?

Regards,
Ismail

1 Like

We are now seeing the notices of a failed analysis:

Last analysis failedAnalysis ID “AYm9DZs-NUGFwbWeH8lH”

The last analysis has failed. If it keeps on failing after several attempts, please contact us on Community forum and provide the following failing analysis ID: “AYm9DZs-NUGFwbWeH8lH”.

At this time - with the github app even though it is bound to our github instance its ability to scan - specifically on branch protection rules still isnt working we tried to suspend , even reinstall and rebind the sonarcloud app but nothing.

1 Like

Hi Erick,

So it seems like our fix worked if you are now able to see the failed status.

I looked at our logs and there is the following scanner error for the analysis ID “AYm9DZs-NUGFwbWeH8lH”:

ERROR: Error during SonarScanner execution
ERROR: Issue exclusions are misconfigured. File pattern is mandatory for each entry of 'sonar.issue.ignore.multicriteria'

Can you check that your configuration is correct in the UI or in the sonarcloud.properties file?

1 Like

Ive set it to empty - before there was the definition css:S4649 as the rule key pattern

however (as none of the scans were occurring for the past month we removed it as a blocker in our workflow -

even though it is bound to our account the app still hasnt connected the repo and will not allow for branch protection rules for scanning

for another one -
image.pngthis was the latest however it hasnt run since then- even if a scan were to fail i would expect to see a failure in the past few days.

So after some time it showed up by itself after we took out the css:S4649 definition - no more silent failures either. THank you - feel free to archive this and we will open up another ticket on where to place ignoring specific bugs such as css:S4649

image.png

2 Likes

Glad it worked out.

If you want to disable some rules you can do it in your Quality Profile by deactivating specific rules.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.