Analyze Fails without any changes to build.yml

build.txt (1.3 KB) (2.7 MB)

we have an android repository setup in GitHub. We followed the instructions and used the build.yml from documentation. The setup worked once or twice but now it is failing with no special reason/changes done afterwards. The process is triggered so and it seems to be configured properly.

Our repository languages are Java, JSON, Kotlin, XML.

I attached the logs and the build configuration.

Hey there.

It looks like the issue is with ktlint, not SonarCloud (the analysis doesn’t even start)

2021-12-07T10:47:39.9886433Z Execution failed for task ':app:ktlint'.

You’ll probably want to reach out to the maintainers at pinterest/ktlint for advice.

thank you for your fast reply. I actually spend some time on it by now and you were right it was our configuration of ktlint. I fixed it and now it works charmingly
Thank you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.