After upgrade to 9.4 getting redirected to reauthenticate

First, we have SAML authentication setup through F5 which works fine for accessing the SonarQube application. After upgrade to 9.4, we get presented with popup to “Get the most out of SonarQube”. If we click “Dismiss”, we are redirected to enter Username and password. Users don’t know their password since they authenticated with smartcard. The same thing happens when I try to add a new user, prompted to reauthenticate. Not sure if the problem is a configuration change needed on SonarQube or F5. Any help that can be provided is appreciated. This won’t be sustainable for long…


Thanks for reporting this. Clearly, it shouldn’t be happening. What happens if the user reloads the page?


I found the problem. We added a rule on the F5 to insert a secure header which worked for the site in our dev environment, but hadn’t fully tested all app functionality until after the upgrade. Since IE is no longer supported, needed to make sure everything worked in Chrome and other browsers. It seemed to, until I tried adding a user. Apparently, the response was a 401 error and got redirected to Username and password. I was still authenticated with my original session using smartcard. After removing the rule on the F5, everything works again.

This leads to the next question: If I can’t insert the secure header through the F5, how can I do it on my app server. I’ll check through the documentation on configuring the web server to see if we can address it and will create a new topic if I need help. Thanks!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.