Add www. redirect to sonarcloud.io

sonarcloud

(Michel Zehnder) #1

Out of habit I ALWAYS type http://www.sonarcloud.io, which leads nowhere. Would be nice if it was just a redirect to https://sonarcloud.io :slight_smile:


(Nicolas Bontoux) #2

Hi Michel,

It’s working well on my side (Chrome 67.0.3396.99 and Safari 9.0 on Mac OS).

Raw curl seems pretty affirmative too:

n-b-sonar:~ n-b-sonar$ curl -I http://www.sonarcloud.io/
HTTP/1.1 302 Found
Date: Wed, 25 Jul 2018 09:36:10 GMT
Server: Apache
Strict-Transport-Security: max-age=63072000; preload
Location: https://sonarcloud.io/
Content-Type: text/html; charset=iso-8859-1

(Michel Zehnder) #3

Interesting.

First try:


Fiddler trace:

[Fiddler] The connection to ‘www.sonarcloud.io’ failed.
Error: TimedOut (0x274c).
System.Net.Sockets.SocketException A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 18.197.43.2:80

nslookup:
λ nslookup www.sonarqube.io.
Server: UnKnown
Address: 192.168.253.253

Non-authoritative answer:
Name: www.sonarqube.io
Address: 75.101.133.159

Then I tried doing https://www.sonarcloud.io -> works
And now normal http also works…
Something quirky going on here…


(Eric Hartmann) #4

Hi Michel,

Thanks for reporting this issue. I do confirm that there is an incorrect setup on our side.

We are using HSTS for SonarCloud, so as soon as you have connected through https, the HSTS flag is telling your browser to always use https for sonarcloud.io domain. So the second time you tried to connect, Internet Explorer was automatically redirect you to the https web site without trying to connect to the server.

Cheers,


(Michel Zehnder) #5

Yes, I thought so. Thanks for confirming (and hopefully fixing)


(Nicolas Bontoux) #6

And my bad for the confusion ! Didn’t come to mind that setup could look different from the inside network I’m on. Thanks for following-up @Eric_Hartmann.


(Henri Gomez) #7

Problem fixed, HTTP (80) and HTTPS (443) are now enabled, HTTP redirecting to HTTPS