404 file not found after first try to log in

We (Goldman Sachs) are looking at SonarQube for our developers. If they can test it, and like it, they will start using it. I have it running in single server mode for the testing. No one can get into it from a desktop browser as that we only get the “404 – File not found” error.

Sonarqube Version: 8.5.1.38104

URL: http://sonar01.foliofn.com:8080 <- have tried with https also. Same error, have tried with 9000, 9001, 9002 ports, nothing.

Error message: 404 File not found

Everything stats up and I can see it running. When I use the above URL on my work laptop, this is the only error I see. 404.

I have made of copy of the /home/sonar/sonarqube/web/index.html file and placed it at each directory up to /home – still 404.

Restarted several times, nothing.

Tried finding the api version recommendation – 404

Joined sonarqube community and searched the board. No luck finding anything for this issue.

Location of code: /home/sonar/sonarqube

User id: sonar <- admin user with sudo rights

home dir: /home/sonar

Database: PostgreSQL

DB User id: sonar <- with admin rights assign

Sonarqube is running on the same server. If this works, then we will separate them to different servers.

We are in the process of seeing if it works for what our company needs. Have been trying to get this installed for 3 days. Still stuck at this final error that I have fixed.

/home/sonar/sonarqube/conf/sonar.properties file with only my changes listed:

sonar.jdbc.username=sonar
sonar.jdbc.password=Sonar01
sonar.jdbc.url=jdbc:postgresql://localhost:5432/sonarqube
sonar.web.host=10.70.44.235
sonar.web.context=/sonarqube
sonar.web.port=8080
sonar.path.data=/var/sonarqube/data
sonar.path.temp=/var/sonarqube/temp

/home/sonar/sonarqube/conf/wrapper.conf file with the only change I made:
wrapper.java.command=java

/home/sonar/sonaqube/bin/linux-x86-64/sonar.sh file - no changes by me.

Hi,

Welcome to the community!

It sounds like you’ve configured sonar.web.context, which alters the path at which you’ll find SonarQube. The fact that you’re getting a 404 indicates to me that a web server is up and running - most likely SonarQube’s Tomcat. Now you just need to figure out where it put SonarQube. Check sonar.properties to see :wink:

 
HTH,
Ann